해결)Could not find package "build_runner". Did you forget to add a dependency?



작성시간 :





(수정됨)

에러

$ flutter pub run build_runner build
Deprecated. Use `dart run` instead.
Could not find package "build_runner". Did you forget to add a dependency?

해결 방법

dev_dependencies에 build_runner가 없을 때 나타나는 메세지다.

설명

pubspec.yaml의 dev_dependencies에 build runner가 없기 때문에 build 작업을 수행하지 못하는 것이다.
다음과 같이 build_runner를 추가한 다음, 다시 build하면 정상적으로 작동하는 것을 확인할 수 있다.

# pubspec.yaml
dev_dependencies:
  build_runner: ^2.4.7

build runner dev: https://pub.dev/packages/build_runner/install



태그



공유

하기






white.seolpyo.com